Status

Cisive Enterprise, Driver IQ, and Student Check are unavailable

Incident Report for Cisive

Resolved

The incident has been resolved.
Posted Mar 31, 2026 - 04:59 UTC

Identified

12:41am ET - The issue has been identified and a fix is being implemented.
Posted Mar 31, 2026 - 04:42 UTC

Investigating

We are currently investigating an issue impacting our platform.
Posted Mar 31, 2026 - 04:16 UTC
This incident affected: Cisive Enterprise, API, Driver iQ, and StudentCheck.