Status

IT Service Notification - Intermittent Access Issues for SWFTPrint.com

Incident Report for Cisive

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 15:58 UTC

Investigating

A System Issue has been identified impacting SWFTPrint.com and we are working actively working to correct the issue.
Posted Aug 19, 2026 - 15:44 UTC
This incident affected: ScreenID.