Status

IT Service Notification -System Issue for Enterprise & ScreenID Client Users & Candidate Users

Incident Report for Cisive

Resolved

The issue affecting access to the Enterprise and ScreenID Client Portal & Candidate Portal has been identified and corrected. All systems are confirmed working as expected. IT will continue to monitor closely.
Posted Sep 04, 2025 - 19:29 UTC

Investigating

A System Issue has been identified impacting Enterprise and ScreenID Client Users & Candidate Users. We will update you when we have a resolution.
Posted Sep 04, 2025 - 18:31 UTC
This incident affected: Cisive Enterprise and ScreenID.