Status

IT Service Notification - Brief disruption for SWFTprint.com

Incident Report for Cisive

Resolved

The issue affecting access to the ScreenID site SWFTprint.com has been identified and we believe it has been corrected. IT will continue to monitor closely. Please let us know if you continue to see issues.
Posted Dec 15, 2025 - 14:38 UTC

Investigating

A System Issue has been identified impacting the ScreenID site SWFTprint.com. Users may experience a brief disruption in service.
Posted Dec 12, 2025 - 16:24 UTC
This incident affected: ScreenID.