Status

IT Service Notification - Intermittent Access Issues for Enterprise Client Users & Candidate Users & New Student Check

Incident Report for Cisive

Resolved

The issue affecting access to the Enterprise Client Users & Candidate Users & New Student Check has been identified and corrected. All systems are confirmed working as expected. IT will continue to monitor closely.
Posted 1 month ago. Apr 29, 2025 - 16:11 UTC

Investigating

A System Issue has been identified impacting Enterprise Client Users & Candidate Users. Users can expect errors when using our system. We will update you when we have a resolution.
Posted 1 month ago. Apr 29, 2025 - 15:21 UTC
This incident affected: Cisive Enterprise and StudentCheck.