Status

Extended Maintenance : FRIDAY 6/5

Incident Report for Cisive

Resolved

Maintenance has been completed and this is resolved.
Posted Jun 08, 2026 - 12:51 UTC

Monitoring

We will be performing extended maintenance on servers this Friday 6/5/2026 starting at 9:00 PM until 3:00 AM EST.

During this time the platform will be unavailable.

Orders placed during this time will need to be resubmitted.
Posted Jun 03, 2026 - 23:16 UTC
This incident affected: LicenseManagerPro (LMP), PreCheck, and StudentCheck.