Status

Temporary Delay with Global Sanctions

Incident Report for Cisive

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 15:00 UTC

Identified

We have identified the issue causing a delay in Global Sanctions results. Our team is actively working on a resolution. Users may experience a delay in Global Sanctions search results.
Posted Jun 05, 2025 - 16:28 UTC
This incident affected: Cisive Enterprise.