Status

IT Service Notification - Intermittent Access Issues for Enterprise Client Users & Candidate Users

Incident Report for Cisive

Resolved

The issue affecting access to the Client Portal & Candidate Portal has been identified and corrected. All systems are confirmed working as expected. IT will continue to monitor closely.
Posted Sep 15, 2025 - 17:40 UTC

Investigating

A System Issue has been identified impacting Enterprise I-9 / E-Verify Client Users & Candidate Users. We will update you when we have a resolution.
Posted Sep 15, 2025 - 17:06 UTC
This incident affected: Cisive Enterprise.