Status

PreCheck Reporting Access

Incident Report for Cisive

Resolved

This incident has been resolved. Reports are available.
Posted Jul 28, 2025 - 14:01 UTC

Investigating

A System Issue has been identified impacting PreCheck reporting capabilities. Reports access is temporarily unavailable. We will update you when we have a resolution. PreCheck ordering is working as expected.
Posted Jul 28, 2025 - 13:57 UTC
This incident affected: PreCheck.