Status

IT Service Notification - Intermittent Access Issues for Enterprise Client Portal and StudentCheck Enterprise Candidate Portal

Incident Report for Cisive

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 14:51 UTC

Investigating

A System issue has been identified impacting StudentCheck Enterprise Candidate Portal & Client Portal. Users can expect delays when using our system. We will update you when we have a resolution.
Posted Apr 29, 2025 - 14:40 UTC
This incident affected: Cisive Enterprise, Driver iQ, and StudentCheck.