Status

IT Service Notification - Delays in receiving MVR reports for Driver iQ, Intellicorp, Enterprise clients

Incident Report for Cisive

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 17:21 UTC

Update

We have identified the issue and are waiting for a fix from our partners.
Posted Apr 18, 2025 - 15:57 UTC

Investigating

A System Issue has been identified impacting MVR Results. Users can expect delays. We will update you when we have a resolution.
Posted Apr 18, 2025 - 14:54 UTC
This incident affected: Cisive Enterprise, Driver iQ, and IntelliCorp.